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Which Tutorial is Right for Me?
A number of tutorials for learning about Sentinel LDK are available. We recommend that you
review the information below to ensure that you choose the tutorial that is most appropriate for
your requirements.
All the tutorials are included in the Sentinel LDK Demo kit and Starter kit.

Software Protection and Licensing Tutorial — Sentinel SL (Software-based)
Keys
This tutorial demonstrates how to protect and license an application with Sentinel SL (software)
protection keys.
Requirements: Download the free Sentinel LDK Demo Kit. No hardware keys are required to
perform this tutorial.
The remaining tutorials described below demonstrate how to protect and license an
application with either Sentinel SL (software) or Sentinel HL (hardware) protection keys.

Software Protection and Licensing Tutorial — “Demo Kit” or “Starter Kit”
Sentinel EMS (Entitlement Management System) is used as the back office system to manage
definition of Features and Products and to generate and track customer entitlements.
n

The Demo Kit tutorial uses a provided demonstration hardware key.
Requirements: Obtain the free physical Sentinel LDK Demo Kit from your Gemalto sales
representative or from the Gemalto web site.

n

The Starter Kit tutorial uses your own Sentinel Developer key and Sentinel HL key to
protect and license an application.
Requirements: Purchase the Sentinel LDK Starter kit and Sentinel HL protection keys from
your Gemalto sales representative.

Software Protection and Licensing API Tutorial — “Demo Kit” or “Starter Kit”
These tutorials demonstrate how you can use Sentinel LDK APIs to generate and update licenses.
It is assumed that you would use your own back office systems to handle all ERP functionality.
A Demo Kit tutorial and a Starter Kit tutorial are available as described above.
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Introduction
Thank you for choosing Sentinel License Development Kit (Sentinel LDK) as the method to protect
and license your software against unauthorized use. In this Tutorial, you use the Sentinel LDK
system to protect, license, and distribute software.
The strength, uniqueness, and flexibility of Sentinel LDK are based on two primary principles:
• Protect Once—Deliver Many—Evolve Often™: the concept of separating the software
engineering and business processes
• Cross-Locking: the technology that supports the Protect Once—Deliver Many—Evolve Often
concept, enabling a protected application to work with a Sentinel HL (hardware) or a Sentinel SL
(software) key
All commercial decisions, package creation, and license definitions are executed by product or
marketing managers after the protection has been implemented.
This workflow model provides you with greater flexibility and freedom when defining new sales
and licensing models, including feature-based and component licensing, evaluation, rental,
floating, subscription, trialware (trial/grace), pay-per-use, and more, enabling you to focus on
revenue growth.

Sentinel Keys
You will use the following Sentinel keys to perform the lessons in this tutorial:
n

Sentinel Developer key (yellow), used to protect your programs

n

Sentinel Master key (blue), used for license production.
The Sentinel Master key must stay connected to the Sentinel EMS Server machine.
The Sentinel Developer key and Sentinel Master key are included in the Starter Kit.
These key are referred to as Sentinel Vendor Keys.

n

One or more end-user Sentinel HL keys, used to run the protected program (color
depends on key type). Sentinel HL keys were ordered separately and are provided in a
separate package.

This tutorial is only partially applicable for Sentinel HL Basic keys. Sentinel HL Basic keys can be
used only to protect your programs, and not to set licensing terms.
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Roles
The Sentinel LDK system is role-based, and the tasks you can perform depend on the user roles
assigned to you by the Sentinel LDK Administrator.
In order to enable you to experience the broad functionality of the Sentinel LDK system in this
tutorial, you will have access to all roles. The roles you assume in the various lessons include:
n

Product Manager role
The person, usually a product manager, who determines the product components to be
protected (called Features in Sentinel LDK), how these components are used to define
Products, and the license structure for the Products.

n

Development role
The person, usually a software engineer, who protects the software using Sentinel LDK
Envelope or the Sentinel Licensing API, and performs other development-related tasks,
such as generating the Sentinel Run-time Environment Installer.

n

Customer Services role
The person responsible for performing manual Product activations.

n

Entitlement Manager role
The person responsible for defining and managing customer entitlements (orders).

n

Production role
The person responsible for producing customer entitlements.

In addition, you will assume the role of an end user in order to test, use, and update the products
licensed using Sentinel LDK.

Conventions
Each of the lessons in this tutorial begins with a focused breakdown of the lesson, similar to the
following:
Objective

A short description of the lesson objective

Role in this lesson

The role or roles that you assume during the lesson

Applications used

Sentinel LDK applications you use in the lesson

Lessons in This Tutorial
This tutorial is based on a Windows operating system and includes the following lessons:
n

"Lesson 1: Preliminary Preparation" on page 11
In this lesson, you install the Sentinel LDK system and learn how to launch
Sentinel Vendor Suite. You then introduce your Sentinel Master key and
Sentinel Developer key into the Sentinel LDK system.

Additional Resources

n
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"Lesson 2: Defining Features" on page 15
In this lesson, you use Sentinel EMS to define two programs as Features, which you will
later license and protect.

n

"Lesson 3: Protect Once" on page 17
In this lesson, you use Sentinel LDK Envelope to apply protection to your software.

n

"Lesson 4: Defining Products" on page 21
In this lesson, you use Sentinel EMS to define your offering by defining Products based on
the Features you already defined and protected.

n

"Lesson 5: Defining an Unlocked Trialware Product" on page 25
In this lesson, you use Sentinel EMS to define an Unlocked Trialware Product based on
one of the Products you defined, enabling you to distribute a trial version of your
software later.

n

"Lesson 6: Creating and Distributing an Entitlement for Sentinel SL-protected Software"
on page 29
In this lesson, you lock your protected software to a Sentinel SL key for later distribution.
You will create an entitlement, define a customer, code the Sentinel SL key, and use the
software as an end user. You will also learn how to activate a license, in order to convert
the trial version of a program to a full-featured program.

n

"Lesson 7: Creating and Distributing an Entitlement for Sentinel HL-protected
Software" on page 35
In this lesson, you lock your protected software to a Sentinel HL key for later distribution.
You will create an entitlement, define a customer, code the Sentinel HL key, and use the
software as an end user. You will also learn how to create a license update for a deployed
Product that has its license locked to a Sentinel HL key.

n

"Lesson 8: Using Sentinel Licensing API" on page 41
In this lesson, you learn how to program the memory on Sentinel protection keys.

We recommend that you follow the lessons sequentially to familiarize yourself with the
Sentinel LDK system and to gain a clear understanding of the strength of the Protect Once—
Deliver Many—Evolve Often model, and the flexibility it provides.

Additional Resources
You can use the following resources to help you learn about the Sentinel LDK system:
n

Sentinel LDK Software Protection and Licensing Guide
This book describes Sentinel LDK licensing concepts and provides a detailed overview of
the system.
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n

Sentinel LDK Release Notes
The Release Notes provide information about the current release, including:

n

o

latest enhancements

o

supported platforms

o

available documentation

o

known issues

Instructional videos
A library of instructional videos for Sentinel LDK is available at:
http://sentinelvideos.gemalto.com/

Obtaining Support
You can contact us using any of the following options:
Business Contacts - To find the nearest office or distributor, use the following URL:
https://sentinel.gemalto.com/contact-us-sm/
Technical Support
To obtain assistance in using Gemalto products, feel free to contact our Technical Support team:
n

Customer Support Portal (preferred):
https://supportportal.gemalto.com/csm?id=sentinel

n

Support Essentials (Contact details, support plans, and policies):
https://supportportal.gemalto.com/csm?id=support_essentials

n

For Issues Related to Using the Portal: customerportalsupport@gemalto.com

n

Phone:
o

AMER: 800-545-6608 (US toll free)

o

International: +1-410-931-7520

o

EMEA/APAC: https://supportportal.gemalto.com/csm?id=sentinel
è Click Contact Us

n

E-mail (Use if you cannot submit the technical issue via the portal):
technical.support@gemalto.com

Downloads
You can download installers and other updated components here:
https://sentinelcustomer.gemalto.com/sentineldownloads/
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Lesson 1: Preliminary Preparation
Objective
Applications used

Prepare your computer and Sentinel LDK for the
tutorial
n
n
n

Sentinel LDK Installation Drive
Sentinel Master Wizard
Sentinel Vendor Suite

The procedures in this lesson are required in order for you to be able to implement the processes
outlined in subsequent lessons of this tutorial. They include:
• Instructions for installing the Sentinel LDK software, including Sentinel EMS Server
• Instructions for launching Sentinel Vendor Suite
• Instructions for introducing the Sentinel Vendor keys to the Sentinel LDK system

Installing the Sentinel LDK Software
Before proceeding with this tutorial, install the Sentinel LDK software and the Sentinel EMS Server
on your computer.

W ARN I N G
Do not c onne c t any of your Se ntine l ke ys be for e installing the Se ntine l L DK
softw ar e !

For instructions on how to install Sentinel EMS and Sentinel LDK Vendor Tools, refer to the
chapter “Installing Sentinel LDK for Windows” in the Sentinel LDK Installation Guide.
During the installation procedure, you can accept all defaults. When prompted to choose a setup
type for Sentinel EMS, click the Express option.
After the installation has completed, select All Programs > Gemalto Sentinel > Sentinel LDK >
Check for Updates from the Start menu. The Software Manager window will indicate to you if a
later version of any of the Sentinel LDK software is available from Gemalto servers. If a later
version is available, select the option to install it.
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Launching Sentinel Vendor Suite
After completing the installation, launch Sentinel Vendor Suite as follows:

1. If you are not certain that the Tomcat service is active: From the Start menu, select
Programs > Gemalto Sentinel > Sentinel EMS > Start EMS Service.
2. From the Start menu, select Programs > Gemalto Sentinel > Sentinel LDK > Vendor Suite.
The Sentinel Vendor Suite program selection screen is displayed. You can access the primary
Vendor Suite applications from this screen.

Introducing the Sentinel Vendor Keys
Sentinel Vendor keys (Sentinel Master key and Sentinel Developer key) enable you to apply
Sentinel LDK protection to your software and data files, to program the Sentinel protection keys
that you send to your end users, and to specify the license terms under which your software can
be used.
The Sentinel Developer key is used by your software engineers in conjunction with the
Sentinel LDK protection applications to protect your software and data files. The Sentinel Master
key is connected to the Sentinel EMS Server computer and used in conjunction with Sentinel EMS
for defining Features and Products, applying license terms, and producing entitlements.
In order to complete this tutorial, you need to introduce your Sentinel Vendor keys to the
Sentinel LDK system.
To introduce your Sentinel Vendor keys:

1. After starting the EMS (Tomcat) service, connect your Sentinel Developer key and your
Sentinel Master key to a USB port. (Ensure that the Sentinel Master key is connected to the
Sentinel EMS Server machine).
2. Start Sentinel Master Wizard as follows:
n

From the Start menu, select: Programs > Gemalto Sentinel > Sentinel LDK > Tools
> Sentinel Master Wizard
If you open either Sentinel LDK Envelope or Sentinel LDK ToolBox, and the
application detects a new Sentinel Vendor key, the Master Wizard will
launch automatically.

3. In the User Name and Password fields, type admin; then click OK.
4. Accept all defaults through the completion of the wizard.
The first time the Master wizard is run for a specific Master key, Gemalto servers
generate and download your customized API libraries. This process typically require
about 20 minutes to complete. However, if there is a backlog, the generation
process may require up to several hours to complete.

Introducing the Sentinel Vendor Keys
The generated APIs are located in the following directory, under the appropriate
subdirectory:
%HomePath%\Documents\Gemalto\Sentinel LDK 7.8\API\Runtime\
5. Click Finish to close the wizard. This process introduces the data in your key to the
Sentinel LDK system and extracts your company’s unique confidential Vendor Code.
For additional information on Vendor Codes, see Understanding Sentinel LDK Software
Protection and Licensing in the Sentinel LDK Software Protection and Licensing Guide.
You are now ready to start the tutorial.
Sentinel EMS provides a notification facility for your Master key. This facility can send
automatic e-mail reminders when:
n

any of the license modules on the Master key are about to expire.

n

the pool of new SL keys or network seats on the Master key falls below a certain
threshold.

Gemalto highly recommends that you configure the notification facility to send reminders
as necessary. In the Sentinel EMS screen, on the main menu, click Administration >
Master. Follow the instructions to configure e-mail reminders.
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Lesson 2: Defining Features
Objective

Learn how to define Features

Role in this lesson

Product Manager

Applications used

Sentinel EMS

This lesson is not applicable for Sentinel HL Basic keys.
A Feature is an identifiable functionality of a software application that can be independently
protected or licensed. In Sentinel LDK, a Feature may be an entire application, a module, or a
specific functionality such as Print, Save, or Draw.
Features are typically defined by the Product Manager based on business decisions, and are then
implemented by the company’s software engineers.
In this lesson, you assume the Product Manager role and use Sentinel EMS to define two Features
for use in subsequent lessons.
To launch Sentinel EMS:

1. From the Start menu, select Programs > Gemalto Sentinel > Sentinel EMS > Launch
Sentinel EMS. Sentinel EMS is launched in a Web browser. The Sentinel EMS Login screen is
displayed.
2. In the User ID and Password fields, type admin.
3. Click Login. The Sentinel EMS Home screen is displayed. Click the Catalog tab to see a
typical web screen.
Sentinel EMS web screens typically includes the following:
n

Function bars, in which you select the function to perform

n

Main pane, in which you view and select items

n

Details pane, in which you view details of the item selected in the Main pane

n

Task buttons, which you use to perform actions
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Defining a Feature for the Sample Bouncing Ball Program
In this section, you define a Feature for an existing program, the Bouncing Ball sample program
supplied with Sentinel LDK.
To define the Bounce Feature:

1. From the function bar of the Sentinel EMS screen, click Catalog > Features. The Features
screen is displayed. This screen shows the list of Features defined and displays details of the
current Feature.The right side of the screen contains task buttons for the tasks that can be
performed in this screen.
2. Click New Feature. The Create Feature screen is displayed.
3. In the Feature Name field, type Bounce.
4. In the Feature ID field, erase the default value and type 50.
5. Click Save. The Create Feature screen closes and the “Bounce” Feature you defined is
displayed in the main pane of the Features screen.

Defining a Feature for the MyNotepad Program
In this section, you define a Feature for the MyNotepad program. You will create the MyNotepad
program in Lesson 3: Protect Once.
To define the MyNotepad Feature:

1. In the Sentinel EMS screen, display the Features screen.
2. Click New Feature. The Create Feature screen is displayed.
3. In the Feature Name field, type MyNotepad.
4. In the Feature ID field, erase the default value and type 10.
If a message is displayed informing you that this Feature ID is not available, do not
use a different Feature ID number. Close the Add Feature screen, and in the main
pane of the Features screen, identify Feature 10 and note its name. For the
remainder of this tutorial, continue to use Feature ID 10, with the name you noted
(instead of MyNotepad).
5. Click Save. The Create Feature screen closes and the MyNotepad Feature you defined is
displayed in the main pane of the Features screen.
6. Close the Sentinel EMS browser window.

3
Lesson 3: Protect Once
Objective

Learn how to apply Sentinel LDK automatic
protection functionality

Role in this lesson

Development

Applications used

Sentinel LDK Envelope

In this lesson, you use Sentinel LDK Envelope to define protection parameters for two programs,
using the two Features you defined earlier.
Sentinel LDK Envelope is an innovative, advanced solution for protecting software against illegal or
unauthorized use. The solution deters illegal access and execution of protected applications.
A deployed Sentinel LDK-protected program requires access to a Sentinel protection key in order
to run. The protected program queries the Sentinel protection key for predefined information. If
the Sentinel protection key is not present, or the information returned is incorrect, the program
does not execute, or stops functioning.

Protecting the Sample Bouncing Ball Program
In this section, you launch Sentinel LDK Envelope and identify the Vendor Code with which you
will protect the software. You then define an end-user error message. Finally, you protect the
Bouncing Ball program.
The Sentinel LDK Envelope window includes the following:
n

Project pane, in which you select the function to perform

n

Display pane, in which you select items and perform actions. The name of the pane
changes to reflect the function you selected in the Project pane—for example, in the
screen below, the Display pane has the title Programs.

n

Log pane, in which Sentinel LDK Envelope messages are displayed
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To prepare for protection:

1. Connect the Sentinel Developer key.
2. From the Start menu, select Programs > Gemalto Sentinel > Sentinel LDK > Vendor Suite.
The Sentinel Vendor Suite program selection window is displayed.
3. Click Envelope to launch Sentinel LDK Envelope. The Sentinel LDK Envelope main window is
displayed.
4. Before protecting an application, Sentinel LDK Envelope must identify the correct Vendor
Code. In the Sentinel LDK Envelope Project pane, select Sentinel Vendor Code.
5. In the right pane of the Sentinel Vendor Code window, click Toggle connection with the
Server. The Log In to Sentinel EMS screen is displayed.
6. Enter the user name and password to log in to Sentinel EMS; then click OK. (The default
user name and password are admin – admin.) The available Vendor Codes are displayed in
the Sentinel Vendor Codes pane.
7. Select Use Vendor Code from Database, and then select the relevant Vendor Code.
Your Vendor Code file is named according to the Batch Code labeled on your
Sentinel keys. For example, if your keys are labeled with the Batch Code ABCDE,
your Vendor Code file is called ABCDE.hvc.

Protecting the MyNotepad Program
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To protect the Bouncing Ball program:

1. In the Sentinel LDK Envelope Project pane, select Programs.
2. Click Add Programs in the top right of the Programs pane.
The Add Programs window is displayed, showing the contents of the \VendorSuite\samples
folder.
If a different folder is displayed, browse to:
%ProgramFiles(x86)%\Gemalto Sentinel\Sentinel LDK\VendorTools\VendorSuite\samples\
3. Select Win32_Bounce.exe and click Open. Win32_Bounce is now listed in the Programs
pane.
4. In the Project pane, under Programs, select Win32_Bounce. The Display pane lists the
Protection Details.
5. In the Name field (to the right of the Feature ID field), select Bounce from the drop-down
list (the Feature that you defined for the Bounce program in Lesson 2: Defining Features).
If you are using a Sentinel HL Basic key, select 0 in the Feature ID field.
6. In the Project pane, under Default Protection Settings, select Windows. The Display pane
now displays Windows - Default Protection Settings.
7. In the Windows - Default Protection Settings pane, decrease the number of Periodic
background checks from the default value to 5 seconds. This means that during run-time,
the protected program will check every 5 seconds to ensure that the required Sentinel HL
key is connected.
8. In the Project pane, under Programs, select Win32_Bounce, then in the Display pane, click
Protect Selected. A message informs you that the protection process is running.
9. Click Close when Sentinel LDK Envelope notifies you that the protection process has
completed.
The protected Bouncing Ball program is saved in this folder:
%HomePath%\Documents\Gemalto\Sentinel LDK 7.8\VendorTools\VendorSuite\Protected

Protecting the MyNotepad Program
In this section, you create a copy of the Gemalto text viewer sample application, define protection
parameters for protecting it using the MyNotepad Feature, and protect the program.
This section is not applicable for Sentinel HL Basic keys.
To protect the MyNotepad program:

1. Locate the Gemalto text viewer application (textviewer.exe). This utility can be found
under:
%ProgramFiles(x86)%\Gemalto Sentinel\Sentinel LDK\VendorTools\VendorSuite\samples\
2. Create a copy of the text viewer application and rename it MyNotepad.exe.
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3. Verify that your Sentinel Developer key is connected to your computer.
4. If it is not already open, launch Sentinel LDK Envelope. The Sentinel LDK Envelope main
window is displayed.
5. Select the program to protect:
a. In the Sentinel LDK Envelope Project pane, select Programs.
b. Click Add Programs in the top right of the Programs pane.
The Add Programs window is displayed.
c. Navigate to the folder where MyNotepad.exe is located. Select the file and click Open.
Note that a new MyNotepad entry is displayed in the Project pane under Programs.
6. Protect the selected program:
a. In the Project pane, under Programs, select MyNotepad. The Display pane lists the
Protection Details.
b. In the Feature ID field, type 10 (the Feature defined for the MyNotepad program in
Lesson 2: Defining Features).
c. In the Project pane, under Default Protection Settings, select Windows. The Display
pane now displays Windows - Default Protection Settings.
d. In the Windows - Default Protection Settings pane, ensure that Periodic background
checks is set to 5 seconds.
e. In the Project pane, under Programs, select MyNotepad, then in the Display pane,
click Protect. A message informs you that the protection process is running.
f. Click Close when Sentinel LDK Envelope notifies you that the protection process has
completed. The protected MyNotepad program is saved in this folder:
%HomePath%\Documents\Gemalto\Sentinel LDK
7.8\VendorTools\VendorSuite\Protected
7. Close Sentinel LDK Envelope. You are prompted to save the changes to the current project.
8. Click Save. The Save As dialog box is displayed.
9. In the File Name field, type Tutorial and click Save.The dialog box closes and the project
is saved.

4
Lesson 4: Defining Products
Objective

Learn how to define the Products you want to
license

Role in this lesson

Product Manager

Applications used

Sentinel EMS

This lesson is not applicable for Sentinel HL Basic keys.
A Product is a licensing entity that represents one of the vendor’s marketable software products.
The Product is coded into the memory of a Sentinel key and contains one or more Features.
License terms are defined for each Feature in a Product.
Like Features, Products are defined using Sentinel EMS. Typically, this function is performed by the
Product Manager, and implemented by the software engineer. In a true production environment,
a number of Products might be defined and held in readiness for inclusion in customer
entitlements. However, you can define new Products—mixing and matching Features—at any
time.
In this lesson, you define a number of Products. The Products will include license terms for the
Bounce and MyNotepad Features you defined in Lesson 2: Defining Features. The Products that
you define now will be included in the entitlements you define in later lessons.
In this lesson, you define the following Products:
n

“Bounce_Lite”—A “rental” Product, in which the license expires after three executions

n

“Bounce_Full”—A “full-featured” Product, in which the license enables unrestricted access
to all the Features in the program. This Product will be created by duplicating the “rental”
Product and modifying the license terms.

n

“MyNotepad_Full”— A “full-featured” Product that enables unrestricted access to all the
Features in the program
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In Lesson 6: Creating and Distributing an Entitlement for Sentinel SL-protected Software,
and Lesson 7: Creating and Distributing an Entitlement for Sentinel HL-protected Software
you will assume the role of an end user, and will install licenses and run these Products.

Defining a Product With an Execution-based License
In this lesson, you define a Product based on the Bounce Feature (ID 50), with a license that
enables the program to be launched three times. Following the third execution, the license must
be updated to enable further use of the program.
To define a Product:

1. Launch Sentinel EMS.
2. From the function bar in the Sentinel EMS screen, select Catalog > Products. The Products
screen is displayed.
3. Click New Product. The Create Product screen is displayed.
4. In the Name field, type Bounce_Lite.
5. In the Locking Type field, select HL or SL (AdminMode or UserMode). This option enables
the protection type to be determined at the time when each entitlement is defined.
6. On the Product Features tabbed page, click Add Features.
7. On the Add Features to Product screen, select the check box next to the Bounce Feature
and click Add Features to Product.
8. On the Product Features tabbed page, click Configure on the Bounce Feature line to
specify the license terms for the Feature. The Configure License Terms screen is displayed.
9. In the License Type field, select Execution Count.
10. Under License Terms:
a. Clear the check box for Specify at entitlement time.
b. In the Executions field, type 3.
11. Click Save. The Configure License Terms screen closes and the license terms are displayed in
the License Terms column.
12. Click Save as Complete. The new Bounce_Lite Product is displayed in the Products screen.
The status for the Product is listed as Complete. This indicates that the Product is available
for distribution.

Defining Products With Full-Featured Licenses
In this section, you duplicate existing Products in order to define two additional Products:
n

A Product based on the Bounce Feature (ID 50), with a perpetual license that will allow the
end user unlimited access to the program. This Product will later be used to update the

Defining Products With Full-Featured Licenses
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limited, execution-based Bounce_Lite Product to a full-featured license.
n

A Product based on the MyNotepad Feature (ID 10), with a perpetual license that will
allow the end user unlimited access to the program. In Lesson 5: Defining an Unlocked
Trialware Product, you will define an evaluation MyNotepad Product. The MyNotepad_
Full Product you define in this lesson will later be used to update the evaluation license to
a full-featured license.

To define the Bounce_Full Product:

1. From the function bar in the Sentinel EMS screen, select Catalog > Products. The Products
screen is displayed.
2. Click New Product. The Create Product screen is displayed.
3. In the Name field, type Bounce_Full.
4. In the Locking Type field, select HL or SL (AdminMode or UserMode). This option enables
the protection type to be determined at the time when each entitlement is defined.
5. On the Product Feature tabbed page, click Add Features.
6. On the Add Features to Product screen, select the check box next to the Bounce Feature
and click Add Features to Product.
7. On the Product Features tabbed page, note that the License Type for the Bounce Feature is
Perpetual by default. Therefore, it is not necessary to perform any additional configuration
for the Feature.
8. Click Save as Complete. There are now two items listed in the Products screen: Bounce_Lite
and Bounce_Full. The status for the Bounce_Full Product is listed as Complete.
To define the MyNotepad_Full Product:

1. From the function bar in the Sentinel EMS screen, select Catalog > Products. The Products
screen is displayed.
2. Click New Product. The Create Product screen is displayed.
3. In the Name field, type MyNotepad_Full.
4. In the Locking Type field, select HL or SL (AdminMode or UserMode). This option enables
the protection type to be determined at the time when each entitlement is defined.
5. On the Product Feature tabbed page, click Add Features.
6. On the Add Features to Product screen, select the check box next to the MyNotepad
Feature and click Add Features to Product.
7. To define memory data, click the Memory tab (next to the Product Features tab), and then
do the following:
a. Click New. The New Memory Segment screen is displayed.
b. In the Offset field, type 0. (Afterward, this will change automatically to 0x0000).
c. In the Length field, type 16.
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d. In the Text field, type Hello World.
e. Click Save. The screen closes. In the Memory Map at the bottom of the Memory
tabbed page, the content of the memory is displayed.
8. Click Save as Complete. The Create Product screen closes. The main pane of the Products
screen now contains the three Products that you defined in this lesson: Bounce_Lite,
Bounce_Full, and MyNotepad_Full.

5
Lesson 5: Defining an Unlocked
Trialware Product
Objective

Learn how to define an Unlocked Trialware Product
that can be supplied as a trial product

Role in this lesson

Product Manager, Development

Applications used

Sentinel EMS

This lesson is not applicable for Sentinel HL Basic keys.
In this lesson, still in the Production Management role, you define the “MyNotepad_Evaluation”
Product as a trial version of the “MyNotepad_Full” Product you defined in Lesson 4: Defining
Products. You then assume the Development role to prepare the Product for distribution by
creating a customized Sentinel Run-time Environment Installer executable file.
An Unlocked Trialware Product is typically used for evaluation purposes, to enable the provision of
a grace period, or for super-distribution. An Unlocked Trialware Product can be used on any
computer for a limited time period. After the allotted period expires, the software no longer runs,
until it is activated with a Sentinel protection key.

Defining an Unlocked Trialware Product
In this section, in the Production Management role, you define the “MyNotepad_Evaluation”
Product—an Unlocked Trialware Product that is a trial version of the “MyNotepad_Full” Product,
with a license that expires 60 days after the application is first used.
To define an Unlocked Trialware Product:

1. From the function bar in the Sentinel EMS screen, select Catalog > Products. The Products
screen is displayed.
2. In the list of Products, select the MyNotepad_Full Product.
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3. From the task buttons, select Actions > Unlocked. The Create Unlocked Product screen is
displayed.
4. In the Name field, type MyNotepad_Evaluation. Note that:
n

The Base Product field displays MyNotepad_Full.

n

The MyNotepad Feature you defined in Lesson 2: Defining Features is included in
the Product with the Unlocked (Time Period) license type. For an Unlocked
Trialware license, the user is granted a usage period of 30 days by default.

5. On the Product Features page, click Configure for the MyNotepad Feature.
6. In the Configure License Terms screen, change the value for Number of Days from 30 to 60.
7. Click Save. The Configure License Terms screen closes.
8. Click Save as Complete.

Defining a Bundle of Unlocked Trialware Products
In this section, you assume the Development role. You bundle the “MyNotepad_Evaluation”
Unlocked Trialware Product that was defined by the Product Manager. You then create a
Sentinel LDK Run-time Environment Installer executable file. (In a true production environment,
you would embed this file in your own application installer.)
To define a bundle of Unlocked Trialware Products:

1. From the function bar in the Sentinel EMS screen, select Developer > Bundle Unlocked
Products. The Bundle Unlocked Products screen is displayed.
2. Verify that the correct Batch Code is displayed in the Batch Code field.
3. Select the task Actions > Add. The Products screen is displayed.
4. Select the MyNotepad_Evaluation entry and click OK. The Products screen closes and the
MyNotepad_Evaluation Product is displayed in the Bundle Unlocked Products screen.
An Unlocked Products bundle can contain any number of Unlocked Trialware
Products. In this procedure, you are only adding a single Unlocked Trialware
Product—MyNotepad_Evaluation—to the Unlocked Products bundle.
5. In the Product Details pane, select the check box for the MyNotepad_Evaluation Product.
6. Click Produce V2C. The V2C file is generated.
7. Choose the option to save the file. The file is saved to:
%HomePath%\Documents\Downloads\
The location to which the file is saved may vary depending on your operating
system and web browser. For the remainder of the lessons in this tutorial, this
location is referred to as the Download location.

Creating a Sentinel Run-time Environment Installer
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Creating a Sentinel Run-time Environment Installer
Remaining in the Development role, you now create a Sentinel Run-time Environment Installer
executable that includes the V2C file you created. The Run-time Environment may be required on
the end user’s computer in order for your Sentinel LDK protected and licensed program to
function correctly. (This depends on the type of protection key that you will be providing. For this
tutorial, you will install the Run-time Environment.)
You need only embed the installer in your software setup to create a ready-to-run Sentinel LDK
protected and licensed program. In this scenario, you have already specified that the MyNotepad
program will run in Trial mode for a maximum of 60 days.
To generate a Sentinel Run-time Environment Installer executable:

1. From the function bar in the Sentinel EMS screen, select Developer > RTE Installer. The RTE
Installer screen is displayed.
2. Verify that the correct Batch Code is displayed in the Batch Code field.
3. Select the Include V2C for Bundle of Unlocked Products check box.
4. In the V2C File Location field, click the browse button.
In the Choose File to Upload dialog box, browse to the Download location (described on
page 26) where you saved the V2C file.
5. Select the V2C file displayed in this location and click Open. The selected file is displayed in
the V2C File Location field of the RTE Installer screen.
6. In the Installer Type field, ensure that the Application (EXE) option is selected.
7. Click Generate. The message RTE file is being created is briefly displayed.
8. Choose the option to save the file. The file haspdinst.exe is saved to the Download location
(described on page 26).
Do not execute the generated file at this time! You will install this bundle in Lesson 6:
Creating and Distributing an Entitlement for Sentinel SL-protected Software.
You are now ready to ship your Product with its license locked to either:
n

a Sentinel SL key, as described in Lesson 6: Creating and Distributing an Entitlement for
Sentinel SL-protected Software, or

n

a Sentinel HL key, as described in Lesson 7: Creating and Distributing an Entitlement for
Sentinel HL-protected Software

6
Lesson 6: Creating and Distributing
an Entitlement for Sentinel
SL-protected Software
Objective

n

n

Role in this lesson

n
n
n

Applications used

n
n
n

Learn how to define an entitlement locked to a Sentinel SL key,
specify the customer for the entitlement, and produce the
entitlement.
Simulate a variety of end-user interactions with programs
protected by Sentinel protection keys.
Entitlement Manager
Production
End User
Sentinel EMS
Sentinel EMS Customer Portal
Admin Control Center

This lesson is not applicable for Sentinel HL Basic keys.
In this lesson, you assume the Entitlement Manager role and define an entitlement. For the order
process, you also define the customer and produce the entitlement so that it is ready for shipment.
The entitlement you define is based on the “MyNotepad_Full” Product that you defined in Lesson
4: Defining Products. The license is locked to a Sentinel SL key that will be activated on the enduser’s machine to convert the trial MyNotepad software to a full-featured product.
When you defined the Products, you specified the license terms for the Features included within
those Products at that time. Note that instead of specifying the license terms when you defined
the Product, you could have enabled the functionality for specifying the license terms at this stage
as part of order processing.
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In this lesson, you will also assume the end-user role to install and use the Product. You will then
use the Sentinel SL Product Key received from the vendor to convert a trial version of the software
to a full-featured program.
When a customer wants to purchase additional Features or to extend the current license
for a Product that has its license locked to a Sentinel SL key, you can update the deployed
license, as described in "Creating an Update for a License in the Field" on page 38.

Defining a Perpetual License With a Product Key
In this section, you create an entitlement for the “MyNotepad_Full” Product that you defined in
Lesson 4: Defining Products, locked to a Sentinel SL key. This license will then be used to convert
the trial MyNotepad_Evaluation Product you defined in Lesson 5: Defining an Unlocked Trialware
Product to a full-featured product.
To define an entitlement with a perpetual license:

1. From the function bar in the Sentinel EMS screen, select Customers. The Customers screen
is displayed.
2. Click New Customer. The Create Customer screen is displayed.
3. Ensure that the type Company is selected.
4. In the Company Name field, type Bob Doe Ltd.
5. In the Contact Information pane, enter your own (or any other) name and e-mail
information.
6. Click Save. The new customer is listed in the Customer screen.
7. From the function bar in the Sentinel EMS screen, select Entitlements. The Entitlements
screen is displayed.
8. Click New Entitlement. The Create New Entitlement screen is displayed.
9. In the Customer field, type Bob.
10. Select Bob Doe Ltd. from the list of customers that appears. The full name of the customer
is displayed.
11. In the Product Details pane, click Add Product.
12. In the Product Selection screen, select the check box for MyNotepad_Full and click Add
Product to Entitlement. The MyNotepad_Full Product is added to the Product list.
13. Select the check box for MyNotepad_Full.
14. For Entitlement Type, ensure that Product Key is selected. Accept all other default values.
15. Click Produce. The Download Product Keys screen is displayed.
16. Click Download.
17. Choose the option to save the file. The file is saved to the Download location (described on
page 26).

Installing a Trial Product
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In the Entitlements screen, the new entitlement is displayed with the status Product Keys
Generated.

Installing a Trial Product
In this section, you simulate the experience of the end user when installing and running your
MyNotepad “trial” software program.
Although in a true production environment your software engineer would typically embed the
Run-time Environment installation which includes the trialware license (for trial use) into your
software installation so that it executes as part of the installation process, in this tutorial you
perform several installation and simulation steps.
To install the Sentinel Run-time Environment and trialware license on an end-user machine:

1. From the Start menu, select Run.
2. Click Browse and navigate to the Download location (described on page 26) that contains
the RTE Installer (haspdinst.exe) that you created earlier.
3. Select the haspdinst.exe file and click Open. The browse window closes and the file path is
displayed in the Open field.
4. In the Open field, type a space followed by -i at the end of the file path.
For example:
"C:\Users\Thomas\Downloads\haspdinst.exe" -i

5. Click OK. The Sentinel Run-time Environment is installed and a success message is
displayed.
To confirm the license status of the trial Product:

1. Navigate to the following folder:
%HomePath%\Documents\Gemalto\Sentinel LDK 7.8\VendorTools\VendorSuite\Protected
2. Double-click MyNotepad.exe.
3. While the application is running, from the Start menu, select All Programs > Gemalto
Sentinel > Sentinel LDK > Tools > Admin Control Center. (The Admin Control Center is
part of the Run-time Environment.)
4. In the Options pane, select Sentinel Keys. All the Sentinel protection keys that are
accessible on the Sentinel License Manager are displayed.

5. Locate the entry for your key and click the Features button in the Actions column. The
Features that are licensed in your key are displayed. Note that the Logins field shows that
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there is currently one login to MyNotepad_Evaluation and that the Restrictions field for
Feature ID 10 indicates that the 60-day trial has begun.
6. Close the MyNotepad program.

Notifying the Customer
Sentinel EMS can be configured so that when you produce an entitlement, Sentinel EMS
automatically sends an email notification to the customer. This email contains the Product Key
and a link to the Sentinel EMS Customer Portal.
The Customer Portal is a web portal in your installation of Sentinel EMS that your customers
access to activate the licenses for their full-featured Products.
A typical email notification looks like this:

This notification provides all the information that the customer needs to activate the Product.
To simplify this tutorial, we did not configure Sentinel EMS to send email notifications, so we will
simulate the end-user experience.

Activating a License With a Product Key
In this section, still in the role of the end user, you assume that you have purchased the
MyNotepad_Full program and received an email notification from the vendor. You use the
Product Key to convert the trial version of the software to a full-featured program that is locked
to your machine.
To activate the protected program:

1. To access the Customer Portal, the customer would click a link provided in the email
notification.

Activating a License With a Product Key
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To simulate this action, click the link below or enter the URL in your Web browser address
field:
http://localhost:8080/ems/customerLogin.html
The Sentinel EMS Product Key Login screen is displayed.
2. The customer would copy the Product Key from the email notification and paste it into the
Product Key field in the login screen. To simulate this action, open the .txt file that
contains the Product Key you generated earlier in this lesson in "Defining a Perpetual
License With a Product Key" on page 30. This file can be found in the Download location
described on page 26.
Copy the Product Key from the file and paste it into the Product Key field in the login
screen. Click Login.
The Sentinel EMS Activation screen is displayed. This screen contains information about the
entitlement. If the entitlement allows multiple activation, this screen indicates how many
activations remain.
The customer can choose to perform online activation or offline activation.
Offline activation can be used if the license will be installed on a machine from which it is
not possible to access the Customer Portal. This includes downloading a utility from
Sentinel EMS and transferring files manually to and from the target machine.
Most customers will prefer to use online activation.
3. Click Online Activation. A progress indicator is displayed for a few seconds, followed by the
message Activation installed successfully.
4. This marks the end of the activation process. Click Close to dismiss the notice.
5. Open Sentinel Admin Control Center to see that you now have a Perpetual license for
Feature ID 10.

7
Lesson 7: Creating and Distributing
an Entitlement for Sentinel
HL-protected Software
Objective

n

n

n

Role in this lesson

n
n
n

Applications used

n
n

Learn how to define an entitlement locked to Sentinel HL keys,
specify the customer for the entitlement, and produce the
entitlement
Simulate a variety of end-user interactions with programs
protected by Sentinel protection keys
Learn how to update a license in the field
Entitlement Manager
Production
End User
Sentinel EMS
Admin Control Center

This lesson is not applicable for Sentinel HL Basic keys.
In this lesson, you assume the Entitlement Manager role and define two different customer orders.
For the order process, you define an entitlement, define a new customer, and produce the
entitlement so that it is ready for shipment. You also assume the end-user role to test different types
of Sentinel protection keys and licenses.
When a customer wants to purchase additional Features, or to extend the current license for your
protected program, you can update the deployed license without having to recall or redeploy
keys.
In this lesson, you will also assume the Entitlement Manager role and learn how to update the
deployed license.
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The entitlements that you define are based on the Products that you defined in Lesson 4: Defining
Products, and include:
n

An entitlement for the Bounce_Lite Product.

n

An entitlement for the Bounce_Full Product. This entitlement will be used to update the
license on the Sentinel HL key provided to the end user with the Bounce_Lite Product. You
will learn how to convert its functionality from Bounce_Lite to Bounce_Full in the field.

When you defined the Products, you specified the license terms for the Features included within
those Products at that time. Note that instead of specifying the license terms when you defined
the Product, you could have enabled the functionality for specifying the license terms at this stage
as part of order processing.

Defining a “Rental” Product Entitlement With Sentinel HL
Locking
In this section, you define an entitlement for the Bounce_Lite Product, with its license locked to a
Sentinel HL key.
To produce a Sentinel HL key-based entitlement for a customer:

1. From the function bar in the Sentinel EMS screen, select Customers. The Customers screen
is displayed.
2. In the Batch Code field, ensure that your Batch Code is selected.
3. Click New Customer. The Create Customer screen is displayed.
4. Ensure that the type Company is selected.
5. In the Company Name field, type John Smith Ltd.
6. In the Contact Information pane, enter your own (or any other) name and e-mail
information.
7. Click Save. The new customer is listed in the Customer screen.
8. From the function bar in the Sentinel EMS screen, select Entitlements. The Entitlements
screen is displayed.
9. Click New Entitlement. The Create New Entitlement screen is displayed.
10. In the Customer field, type John.
11. Select John Smith Ltd. from the list of customers that appears. The full name of the
customer is displayed.
12. In the Product Details pane, click Add Product.
13. In the Product Selection screen, select the check box for Bounce_Lite and click Add Product
to Entitlement. The Bounce_Lite Product is added to the Product list.
14. Select the check box for Bounce_Lite.

Using an Application With a Sentinel HL Key
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15. For Entitlement Type, select Hardware Key.
16. In the Number of keys field, type 1.
At this point, you can “queue” the entitlement. The procedure that follows could then be
performed by a person in the Production role, who is authorized to use Sentinel EMS only
for the purpose of burning licenses to HL keys and does not have access to other
functions.
To lock the license to a Sentinel HL key:
1. Connect the Sentinel HL key to which you want to burn the entitlement to your computer.
2. Click Produce. The Produce Sentinel HL Key screen is displayed.
3. In the list of keys, select the check box for your Sentinel HL key.
4. Click Burn. A graphical display indicates that the burn is taking place. Upon completion, a
success message is displayed.
5. Close the Update Physical Key screen.

Using an Application With a Sentinel HL Key
When a customer receives an application that you protected with a Sentinel HL key, the actual key
must be accessible by the application in order to run the program. In the following procedure,
you assume the end-user role to test Bounce, with a Bounce_Lite license locked to a Sentinel HL
key.
In this part of the lesson, you use Sentinel Admin Control Center to manage the use of your
licensed software. In a true production environment, a system administrator in your customer’s
organization uses this Web-based application to manage network licenses for your software.
To operate a Product protected with a Sentinel HL key:

1. Connect the Sentinel HL key on which you burned the entitlement to your computer. The
required licensing information for Bounce_Lite is contained, in encrypted format, in the key.
As long as the license is valid, the protected application can run.
2. (Optional) Examine the license on the HL key as follows:
a. From the Start menu, select All Programs > Gemalto Sentinel > Sentinel LDK >
Tools > Admin Control Center. Sentinel Admin Control Center is displayed. This
interface enables customers to track the status and usage of their Sentinel licenses.
b. In the Options pane, select Sentinel Keys. All the Sentinel protection keys that are
accessible on the Sentinel License Manager are displayed.
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c. Locate the entry for your Sentinel HL key and click the Features button in the Actions
column. The Features that are licensed in your key are displayed.
Note that the Restrictions field for Feature ID 50 displays Executions 3 left, indicating
that the remaining number of logins permitted by the license is 3.
3. Navigate to the following folder:
%HomePath%\Documents\Gemalto\Sentinel LDK 7.8\VendorTools\VendorSuite\Protected
4. Double-click Win32_Bounce.exe. The Bouncing Ball program launches.
5. Close the Bounce software.
6. Repeat step 4 and step 5 two more times, to consume all the permitted executions.
7. Repeat step 4. Bounce fails to open and a message is displayed indicating that the Feature
has expired.
8. In Sentinel Admin Control Center, in the Options pane, select Sentinel Keys. All the
Sentinel protection keys that are accessible on the Sentinel License Manager are displayed.
9. Locate the entry for your Sentinel HL key and click the Features button in the Actions
column.
If you are not sure which entry relates to your specific key, click the Blink on button
and identify the key on which the LED is blinking.
Note that the Restrictions field for Feature ID 50 displays Expired, meaning that the number
of allowed logins defined in the license has been exhausted.

Creating an Update for a License in the Field
John Smith requested a license upgrade—from Bounce_Lite to Bounce_Full. In this part of the
lesson, you will assume the Order Management role to create an update for the deployed license,
and the Production role to produce the entitlement for the updated license. You will then assume
the role of the end user (John Smith) to activate the license update.
To produce an entitlement for a license update:

1. From the function bar in the Sentinel EMS screen, select Entitlements. The Entitlements
screen is displayed.
2. Click New Entitlement. The New Entitlement screen is displayed.
3. In the Customer field, type John.
4. Select John Smith Ltd. from the list of customers that appears. The full name of the
customer is displayed.
5. In the Product Details pane, click Add Product.
6. In the Product Selection screen, select the check box for Bounce_Full and click Add Product
to Entitlement. The Bounce_Full Product is added to the Product list.
7. Select the check box for Bounce_Full.

Updating a License at the Customer’s Site
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8. For the Entitlement Type, select the Protection Key Update option.
9. Click Locate. The Located Sentinel Keys screen is displayed.
10. Select Key ID, and then click Locate. The key information is displayed in the upper table.
11. In the list of protection keys, select the check box for John Smith’s Sentinel HL key.
12. Click Add To List. The selected key is added to the Sentinel Keys to Update table.
13. In the Sentinel Keys to Update table, select the check box for John Smith’s Sentinel HL key;
then click OK. The Locate Sentinel Keys screen closes.
14. Click Produce. The Generate License screen is displayed.
15. In License Output Type, select the V2C option.
16. Click Generate. The message V2C generated successfully is displayed at the top of the
screen.
17. In the Activation Details pane, click Download V2C File. Save the file to your desktop.
The file saved is named [KeyID].v2c, where [KeyID] is Key ID of the Sentinel HL protection
key for which the license was generated.
18. Click Close. The Generate License screen closes.

Updating a License at the Customer’s Site
In this section, you retain the role of “John Smith Ltd.” You have purchased a full-featured version
(Bounce_Full) of the program to replace the execution-based Bounce_Lite version. You update
your license using the Sentinel Admin Control Center and the HaspUpdate.v2c file you receive
from the vendor.
To apply a license update:

1. Ensure that the appropriate Sentinel HL key is connected to your computer.
2. Launch Sentinel Admin Control Center, as follows.
From the Start menu, select All Programs > Gemalto Sentinel > Sentinel LDK > Tools >
Admin Control Center. Sentinel Admin Control Center is displayed.
3. In the Options pane, select Update/Attach. The Update/Attach License window is displayed.
4. Click Browse and navigate to your desktop.
5. Select the [HASP KeyID].v2c file that you created when producing the entitlement for the
license update in your Entitlement Manager role earlier, in step 17 on page 39.
6. Click Open. The file path is displayed in the Select a V2C... file field.
7. Click Apply File. A message is displayed confirming that your update was applied
successfully.
8. In the Options pane, select Sentinel Keys.
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9. Locate the entry for your Sentinel HL key and click the Features button. The Features that
are licensed in your key are displayed.
Note that an additional row is created for Feature ID 50. The Restrictions field in this row is
Perpetual, indicating that the remaining number of logins permitted by the license is
unlimited.

10. Navigate to the following folder:
%HomePath%\Documents\Gemalto\Sentinel LDK 7.8\VendorTools\VendorSuite\Protected
11. Double-click Win32_Bounce.exe. The Bouncing Ball program launches.
12. Close the Bouncing Ball program and disconnect the Sentinel HL key.
This lesson demonstrates using Sentinel Admin Control Center to examine licenses and to
update a license at the customer’s site.
Sentinel Admin Control Center is part of the Sentinel LDK Run-time Environment. The Runtime Environment was placed on your computer when you installed Sentinel LDK Vendor
Tools. However, the Run-time Environment is not required for Sentinel HL Driverless keys.
If you have not included the Run-time Environment with your protected application, you
can update licenses at the customer’s site using other methods. For more information, see
the description of the Sentinel Remote Update System in the Sentinel LDK Software
Protection and Licensing Guide.

8
Lesson 8: Using
Sentinel Licensing API
Objective

Learn how to implement Sentinel Licensing API
functions using Sentinel LDK ToolBox

Role in this lesson

Development

Applications used

Sentinel LDK ToolBox

Now that you have completed the other lessons in this tutorial, you should have a good
understanding of how Sentinel LDK works. This lesson builds on your accumulated knowledge and
introduces you to the Sentinel Licensing API through Sentinel LDK ToolBox, which is an interactive
GUI application that helps you familiarize yourself with various Sentinel APIs.
The Sentinel LDK system offers a rich variety of API calls to support customized protection of your
program, as well as other operations on Sentinel protection keys.
You can also use Sentinel LDK ToolBox to generate source code that you can immediately copy
and paste into your own application source code.
The Sentinel LDK ToolBox window contains these elements:
n

API panel, in which you select the API to work with

n

Function pane, in which you select the function to perform

n

Display pane, in which you can view and edit the details of the function call you selected

n

Generated Code pane, in which code is displayed. You can copy this code and paste it
into your own files.

n

Handles pane, in which the session handle is displayed
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To launch Sentinel LDK ToolBox:

1. From the Start menu, select Programs > Gemalto Sentinel > Sentinel LDK > Vendor Suite.
The Vendor Suite program selection window is displayed.
2. Click ToolBox to launch the Sentinel LDK ToolBox application. The Sentinel LDK ToolBox
main window is displayed.
The API panel on the left of the ToolBox window contains all the available APIs. For the
selected API, the available functions are displayed.
3. Browse the list. You can select any API, and then select an available function for that API.
After you select a function, the Display pane on the right of the ToolBox window displays
the parameters that you must specify in order to execute the function call.

Selecting Your Programming Language
Sentinel LDK ToolBox can generate code in several programming languages.
To select your programming language:

1. From the File menu in Sentinel LDK ToolBox, select Settings. The Settings window is
displayed.
2. Select the ToolBox tab.
3. From the Programming language drop-down list, select your preferred language.
For this tutorial, it is recommended that you select C-API. If C-API is not selected,
select it and click OK. If C-API is already selected, click Cancel.
The Settings window closes with the programming language selected.

Starting With Login
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Starting With Login
Each Sentinel Licensing API session typically begins with the hasp_login API call, which establishes
a connection with a Sentinel protection key and enables access to its resources. For this lesson,
you will connect a Sentinel HL key.
hasp_get_info() and hasp_update() are standalone functions. You do not have to log in
before you call these functions.
To log in to the Sentinel HL key:

1. Connect a Sentinel HL key.
2. In the Function pane, select hasp_login. The Display pane displays all the parameters with
the default values that are appropriate for the login operation.
3. Specify the location of your stored Vendor Code file.
To locate your Vendor Code file, click the browse button.
By default, Vendor Codes are stored in:
%HomePath%\Documents\Gemalto\Sentinel LDK 7.8\VendorCodes
The file is named according to the label printed on your keys. For example, if the keys are
labeled with Batch Code ABCDE, by default, your Vendor Code file is named ABCDE.hvc.
4. Select your Vendor Code file and click Open. The code is displayed in the Vendor Code
field.
5. In the Feature ID field, type 50.
You must specify a Feature ID that exists in the protection key. If you did not define
Feature ID 50 earlier in the tutorial or if you are using a Sentinel HL Basic key, select
0 in the Feature ID field.
6. At the bottom left of the hasp_login pane, click Execute. The result of the executed login is
summarized to the right of the Execute button in three Status fields—number, code and
message.

Encrypting Data and Writing to Memory
Now that you have established a session with the connected Sentinel protection key, you can access
its resources through other API calls.
One of the most important and powerful resources available in a Sentinel protection key is its
internal encryption engine. You can optimize protection by using this engine and the encryption
facilities in Sentinel LDK as an additional method for verifying that the correct key is accessible
when the protected program is running. To do this, proceed as follows:
n

Encrypt a string using the Sentinel protection key

n

Incorporate the encrypted string into the application source code

44

Lesson 8: Using Sentinel Licensing API

n

Define your source code to send the encrypted string to the key for decryption and then
to verify the result

In its encrypted form, the string prevents the program from running correctly. The protected
program will run only if it can decrypt the string, and this can only be achieved if the
Sentinel protection key is accessible. This section demonstrates how the key encrypts and
decrypts a string.
To encrypt a string:

1. In the Function pane, select hasp_encrypt. The Display pane displays parameters for the hasp_
encrypt API call.
2. Specify the Size as 100.
3. Click the first dot to the right of the memory editor, on the far right of the window, and
type: Gemalto, Inc.
4. Click Execute. Note that the string has been encrypted by the Sentinel protection key and is
now illegible.
Sentinel LDK uses a unique encryption key for each encryption process, based on
your unique Sentinel Vendor keys and the current Feature. Therefore, the string you
type is encrypted differently from any other software vendor (and differently for
each Feature)
5. In the Function pane, select hasp_decrypt. The editor still displays the encrypted string.
6. Click Execute. The Sentinel protection key decrypts the string. Gemalto, Inc. is now
displayed in the editor.
If you are using a Sentinel HL Basic key, you have completed the tutorial. Proceed to
"What’s Next?" on page 45.

Retrieving Sentinel Protection Key Information
Sentinel LDK ToolBox enables you to retrieve key-related information. In this section, you use the
hasp_get_sessioninfo function to retrieve information relating to the identity and memory size
of the Sentinel protection key.
To retrieve Sentinel protection key information:

1. In the Function pane, under Management, select hasp_get_sessioninfo. The Display pane
displays parameters for the hasp_get_sessioninfo API call.
2. In the Display pane, from the Format Template drop-down list, select HASP_KEYINFO. Note
that a description of the Format definition is displayed in the gray box below the
Information field.
3. Click Execute. The Information pane displays XML tags with information on the key,
including:
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n

The unique ID number of the connected key

n

The key Read/Write memory size

n

The key Read-only memory size
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Reading and Programming Sentinel Protection Key Memory
In this section, you log in to Feature ID 10 on the Sentinel SL key that you defined in Lesson 4:
Defining Products. You write to and then read from the memory of the protection key.
To log in to the Sentinel protection key:
n

Follow the Sentinel HL key login procedure on page 43, but this time, in step 5, type 10.

To program the Sentinel protection key memory:

1. In the Function pane, under Memory, select hasp_write. The Display pane displays
parameters for the hasp_write API call and an editor for the Sentinel protection key
memory.
2. In the memory editor, set the Offset field to 16 and the Length field to 24.
3. On the right side of the pane, click the first “.” and type:
The World says Hello

4. Click Execute. The string is stored in the protection key memory.
To read the Sentinel protection key memory:

1. In the Function pane, under Memory, select hasp_read. The Display pane displays
parameters for the hasp_read API call and an editor for the Sentinel protection key
memory.
2. In the memory editor, set the Offset field to 0 and the Length field to 40.
3. Click Execute. The memory editor now displays:
n

the string Hello World, which you stored in the key in Lesson 4: Defining Products.

n

the string that you typed above, in step 3.

What’s Next?
This concludes the Sentinel LDK tutorial. You are now ready to use Sentinel LDK applications to
license your software and protect it against unauthorized use.
For additional information about the Sentinel LDK system, refer to the Sentinel LDK Software
Protection and Licensing Guide and to the Help documentation available in the Sentinel LDK
applications.

